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NI 5650/5651/5652 RF Signal Generator 

This document explains how to install, configure, and test the NI PXIe-5650/5651/5652 
as a stand-alone device. The NI 5650/5651/5652 is a continuous-wave RF signal 
generator with modulation capability. The NI 5650/5651/5652 ships with the NI-RFSG 
instrument driver, which you use to program the device. 

Refer to ni.com/manuals for the most recent specifications document. 

Electromagnetic Compatibility Guidelines 

This product was tested and complies with the regulatory requirements and limits for 
electromagnetic compatibility (EMC) stated in the product specifications. These 
requirements and limits are designed to provide reasonable protection against 
harmful interference when the product is operated in the intended operational 
electromagnetic environment. 

This product is intended for use in industrial locations. However, harmful interference 
may occur in some installations, when the product is connected to a peripheral device 
or test object, or if the product is used in residential or commercial areas. To minimize 
interference with radio and television reception and prevent unacceptable 
performance degradation, install and use this product in strict accordance with the 

Note Before you begin, install and configure your chassis and controller. 

Caution The protection provided by this product may be impaired if it is 
used in a manner not described in this document. 

Hot Surface If the NI 5650/5651/5652 has been in use, it may exceed safe 
handling temperatures and cause burns. Allow the NI 5650/5651/5652 to cool 
before removing it from the chassis. 
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instructions in the product documentation. 

Furthermore, any modifications to the product not expressly approved by NI could 
void your authority to operate it under your local regulatory rules. 

Verifying the System Requirements 

To use the NI-RFSG instrument driver, your system must meet certain requirements. 

Refer to the product readme, which is available online on the driver software 
download page or on the release notes page, for more information about minimum 
system requirements, recommended system, and supported application development 
environments (ADEs). 

Unpacking the Kit 

1. Touch the antistatic package to a metal part of the computer chassis. 
2. Remove the device from the package and inspect the device for loose components 

or any other sign of damage. 

Caution To ensure the specified EMC performance, operate this product 
only with shielded cables and accessories. 

Caution To ensure the specified EMC performance, the length of all I/O 
cables must be no longer than 3 m (10 ft). 

Notice To prevent electrostatic discharge (ESD) from damaging the device, 
ground yourself using a grounding strap or by holding a grounded object, 
such as your computer chassis. 

Notice Never touch the exposed pins of connectors. 
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3. Unpack any other items and documentation from the kit. 

Verifying the Kit Contents 

Figure 1. NI 5650/5651/5652 Kit Contents 
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1. NI PXIe-5650/5651/5652 RF Signal Generator Module 
2. Screwdriver, Part Number 772006-01 
3. Driver Software DVD 
4. NI PXIe-5650/5651/5652 Getting Started Guide (this document) 
5. Read Me First: Safety and Electromagnetic Compatibility 
6. Maintain Forced-Air Cooling Note to Users 

Other Equipment 

There are several required items not included in your device kit that you need to install 
or operate the NI 5650/5651/5652. 

Required Items 

• A PXI Express chassis and chassis documentation. The NI PXIe-1085 chassis is one 

Note Do not install a device if it appears damaged in any way. 

Note Store the device in the antistatic package when the device is not in use. 
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available option for your device. For more information about compatible chassis 
options, refer to ni.com 

• A PXI Express embedded controller or MXI controller system that meets the system 
requirements specified in this guide and chassis documentation. 

Optional Items 

• A 1 N · m standard SMA torque wrench (NI part number 780487-01). 

Preparing the Environment 

Ensure that the environment you are using the NI 5650/5651/5652 in meets the 
following specifications. 

Operating ambient temperature 
(IEC 60068-2-1, IEC 60068-2-2) 0 °C to 55 °C 

Operating relative humidity (IEC 60068-2-56) 10% to 90%, noncondensing 

Maximum altitude 2,000 m (800 mbar) (at 25 °C ambient 
temperature) 

Pollution Degree 2 

Indoor use only. 

Notice Clean the hardware with a soft, nonmetallic brush or lint free cloth. 
Make sure that the hardware is completely dry and free from contaminants 
before returning it to service. 

Note Refer to the NI PXIe-5650/5651/5652 Specifications at ni.com/
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Installing the Software 

You must be an Administrator to install NI software on your computer. 

1. Install an ADE, such as LabVIEW or LabWindows™/CVI™. 
2. Download the driver software installer from ni.com/downloads. 

Package Manager downloads with the driver software to handle the installation. 
Refer to the Package Manager Manual for more information about installing, 
removing, and upgrading NI software using Package Manager. 

3. Follow the instructions in the installation prompts to install the NI-RFSG driver 
software. 

4. When the installer completes, restart your system. 

Installing the NI 5650/5651/5652 

manuals for complete specifications. 

Note Windows users may see access and security messages during 
installation. Accept the prompts to complete the installation. 

Notice To prevent damage to the NI 5650/5651/5652 caused by ESD or 
contamination, handle the module using the edges or the metal bracket. 

Notice 

You must install NI-RFSG before installing the hardware. 

Before you install the hardware, refer to the guidelines in the Maintain 
Forced-Air Cooling Note to Users included with the module to ensure 
that the chassis can cool the device effectively. 
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1. Ensure the AC power source is connected to the chassis before installing the 
module. The AC power cord grounds the chassis and protects it from electrical 
damage while you install the module. 

2. Power off the chassis. 
3. Inspect the slot pins on the chassis backplane for any bends or damage prior to 

installation. Do not install a module if the backplane is damaged. 
4. Remove the black plastic covers from all the captive screws on the module front 

panel. 
5. Identify a supported slot in the chassis. The following figure shows the symbols 

that indicate the slot types. 
Figure 2. Chassis Compatibility Symbols 

1. PXI Express System Controller Slot 
2. PXI Peripheral Slot 
3. PXI Express Hybrid Peripheral Slot 
4. PXI Express System Timing Slot 
5. PXI Express Peripheral Slot 

NI 5650/5651/5652 modules can be placed in PXI Express peripheral slots, 
PXI Express hybrid peripheral slots, or PXI Express system timing slots. 

6. Touch any metal part of the chassis to discharge static electricity. 
7. Ensure that the ejector handle is in the downward (unlatched) position. 
8. Place the module edges into the module guides at the top and bottom of the 

chassis. Slide the module into the slot until it is fully inserted. 
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Figure 1. Module Installation 

1. Chassis 
2. Hardware Module 
3. Ejector Handle in Downward (Unlatched) Position 

9. Latch the module in place by pulling up on the ejector handle. 
10. Secure the module front panel to the chassis using the front-panel mounting 

screws. 

11. Cover all empty slots using either filler panels (standard or EMC) or slot blockers 
with filler panels, depending on your application. 

12. Power on the chassis. 

Related tasks: 

Note Tightening the top and bottom mounting screws increases 
mechanical stability and also electrically connects the front panel to the 
chassis, which can improve the signal quality and electromagnetic 
performance. 

Note For more information about installing slot blockers and filler 
panels, go to ni.com/r/pxiblocker. 
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• Installing the Software 

Installing the SMA Cables 

To use the NI 5650/5651/5652 with other devices, you must make connections using 
SMA cables. For best results when connecting signals to the NI 5650/5651/5652 front 
panel SMA connectors, use shielded low-loss coaxial cables. 

1. Connect the cable center pin on the SMA cable to the SMA connector on the 
appropriate device. 

2. Hand-tighten the SMA cable end on the SMA connector after the cable center pins 
are correctly aligned and connected. The cable connectors should tighten without 
much torque or effort. If a cable bends due to incorrect alignment, remove the 
cable from the front panel connector and repeat step 1 before continuing with this 
step. 

3. Use a 1 N · m torque wrench (not included) or RF torque screwdriver and SMA 
driver bit included in your device kit to complete the tightening of the SMA cable to 
1 N · m. Rotate the torque wrench no more than one revolution to tighten the SMA 
cable before reaching maximum torque. 

Direct Connections to the NI 5650/5651/5652 

The NI 5650/5651/5652 is a precision RF instrument that is sensitive to ESD and 

Notice The signal pins of this product's input/output ports can be damaged 
if subjected to ESD. To prevent damage, remove power from the product 
before connecting cables and employ industry-standard ESD prevention 
measures during installation, maintenance, and operation. 

Note Ensure that the SMA cable center pins properly align with the SMA 
connectors to avoid bending the cable pins or damaging the front panel 
connectors on the device. If the SMA cable does not exactly align with the 
SMA connector, bend the cable slightly by hand to align the cable and the 
connector. The amount of bending should be minimal. The cables can be 
damaged by excessive bending. 
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transients. Ensure you take the following precautions when making direct connections 
to the NI 5650/5651/5652 to avoid damaging the device. 

• Ensure you are properly grounded when manipulating cables or antennas 
connected to the NI 5650/5651/5652. 

• If you are using nonisolated devices, such as a nonisolated RF antenna, ensure the 
devices are maintained in a static-free environment. 

• If you are using an active device, such as a preamplifier or switch routed to the 
NI 5650/5651/5652, ensure no signal transients are sourced to the 
NI 5650/5651/5652. 

NI 5650/5651/5652 RF Signal Generator Module 

The NI 5650/5651/5652 RF signal generator module contains three connectors and two 
multicolor LEDs. 

Note Do not apply external signals to the NI 5650/5651/5652. Applying 
external signals may cause damage. 

Note The following figure depicts the NI 5652 module front panel, although 
each NI 5650/5651/5652 module front panel contains the same connectors 
and LEDs. 
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Figure 4. NI 5652 RF Signal Generator Module Front Panel 
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Table 3. Device Front Panel Icon Definitions 

Refer to the user documentation for required 
maintenance measures to ensure user safety 
and/or preserve the specified EMC performance. 

If this device has been in use, it may exceed safe 
handling temperatures and cause burns. Allow 
the device to cool before removing it from the 
chassis. 

Table 2. NI 5650/5651/5652 RF Signal Generator Module Front Panel Connectors 

Connector Use 

RF OUT Output terminal for the RF signal at the 
requested frequency and power level. 

RF IN/OUT Routes a frequency reference signal to or from 
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Connector Use 

the RF signal generator. 

This connector can be configured as an external 
frequency reference input or as an output for the 
onboard 10 MHz Reference Clock. 

REF OUT2 Routes a frequency reference signal from the RF 
signal generator. 

Table 3. NI 5650/5651/5652 RF Signal Generator Module Front Panel LEDs 

LED Indications 

ACCESS 

Indicates the basic hardware status of the 
module. 

OFF—The module is not yet functional or has 
detected a problem with a PXI Express power 
rail. 

AMBER—The module is being accessed. 
Accessed means that the device setup registers 
are being written to in order to control the 
device. 

GREEN—The module is ready to be programmed 
by NI-RFSG. 

ACTIVE 

Indicates the state of the module. 

OFF—The module is not yet generating a signal. 

AMBER—The module phase-locked loops (PLLs) 
are attempting to lock. 

GREEN—The module is generating a signal; 
applicable PLLs are locked. 
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LED Indications 

RED—The module has detected an error state; 
this state may indicate a PLL lock failure or a 
thermal shutdown condition. 

Verifying the Installation in MAX 

You can use Measurement & Automation Explorer (MAX) to configure your NI hardware. 
MAX informs other programs about which NI hardware products are in the system and 
how they are configured. MAX is automatically installed with NI-RFSG. 

1. Launch MAX. 
2. In the configuration tree, expand Devices and Interfaces to see the list of installed 

NI hardware. If you are using the NI 5650/5651/5652 with the LabVIEW Real-Time 
Module, expand Remote Systems. Find your target IP address or name, expand it, 
and then expand Devices and Interfaces. 
Installed modules appear under the name of their associated chassis. 

3. Expand your Chassis tree item. 
MAX lists all modules installed in the chassis. Your default names may vary. 

4. Record the name MAX assigns to the hardware. Use this identifier when 
programming the NI 5650/5651/5652. 

5. Self-test the hardware by selecting the item in the configuration tree and clicking 
Self-Test in the MAX toolbar. 
MAX self-test performs a basic verification of hardware resources. 

Related information: 

Note MAX is not available on Linux. 

Note If you do not see your module listed, press <F5> to refresh the list 
of installed modules. If the module is still not listed, power off the system, 
ensure the module is correctly installed, and restart. 
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• Refer to the NI RF Signal Generators Help for information about renaming devices. 

Programming the NI 5650/5651/5652 

You can generate signals interactively using the NI-RFSG Soft Front Panel (SFP), or you 
can use the NI-RFSG instrument driver to program your device in the supported ADE of 
your choice. 

Table 4. NI 5650/5651/5652 Programming Options 

Application Programming 
Interface (API) Location Description 

NI-RFSG SFP 

Available from the Start menu 
at Start » All Programs »
National Instruments » NI-
RFSG » NI-RFSG Soft Front 
Panel. 

The NI-RFSG SFP controls, 
generates, and presents data 
similar to stand-alone RF signal 
generators. The NI-RFSG SFP 
operates on the PC, so it 
provides additional processing, 
storage, and display 
capabilities. 

NI-RFSG Instrument Driver 

LabVIEW—Available on the 
LabVIEW Functions palette at 
Measurement I/O » NI-RFSG. 

NI-RFSG configures and 
operates the device hardware, 
performs waveform 
programming and generation, 
and performs basic modulation 
tasks using LabVIEW VIs or 
LabWindows/CVI functions. 

LabWindows/CVI—Available at 
Program Files » IVI Foundation 
» IVI » Drivers » niRFSG. 

Microsoft Visual C/C++ 

Add all required include and 
library files to your project to 
create an NI-RFSG application 
in Microsoft Visual C/C++. 

Related information: 
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• For detailed instructions about how to generate signals in a specific ADE, refer to 
the Getting Started section of the NI RF Signal Generators Help. 

• Refer to the Creating an Application with Microsoft Visual C and C++ topic of the NI 
RF Signal Generators Help to manually add all required include and library files to 
your project. 

NI-RFSG Examples 

Examples demonstrate the functionality of the device and serve as programming 
models and building blocks for your own applications. The NI Example Finder is a 
utility available for some ADEs that organizes examples into categories and allows you 
to easily browse and search installed examples. You can see descriptions and 
compatible hardware models for each example or see all the examples compatible 
with one particular hardware model. 

You can locate LabVIEW or LabWindows/CVI examples with the NI Example Finder. 
Within LabVIEW or LabWindows/CVI, select Help » Find Examples and navigate to 
Hardware Input and Output » Modular Instruments. 

Generating a Signal Using the NI-RFSG Soft Front Panel 

To verify your device configuration, use the NI-RFSG Soft Front Panel (SFP) in MAX to 
generate a simple signal. 

1. Within MAX, select the NI 5650/5651/5652 RF signal generator module in the 
configuration tree. 

2. Select Soft Front Panel from the MAX toolbar. 
The NI-RFSG SFP launches. 

3. Within the NI-RFSG SFP, specify a frequency and a power level for signal 
generation. 

Caution Clicking RF On/Off generates a signal from the RF OUT 
connector of the NI 5650/5651/5652 front panel. Disconnect any 
equipment that can be damaged by the test signal prior to clicking the RF 
On/Off button on the NI-RFSG SFP. 
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4. Click RF On/Off to begin signal generation. 

During signal generation, the ACTIVE LED on the NI 5650/5651/5652 hardware 
module illuminates. 

5. Click RF On/Off to stop signal generation. 

Building a Basic NI-RFSG Application 

You can build a basic NI-RFSG application in LabVIEW for generating continuous sine 
wave signals. 

Adding the Core NI-RFSG VIs to a Blank VI 

Create a new application that includes the core NI-RFSG VIs. 

1. Launch LabVIEW. 
2. To create a blank VI, select File » New VI. 
3. Display the block diagram by selecting Window » Show Block Diagram. 

4. Right-click the VI block diagram to launch the Functions palette. 
5. Navigate to the NI-RFSG VIs on the NI-RFSG palette. 

6. Add the core NI-RFSG VIs from the NI-RFSG palette to the block diagram, and wire 
the VIs together as shown in the following figure. 
Figure 5. Basic NI-RFSG Block Diagram 

Note Refer to the Troubleshooting section of this document if an 
ACTIVE LED does not turn on or if the NI-RFSG SFP generates an error. 

Tip Activate the LabVIEW context help by selecting Help » Show Context 
Help. 

Tip You can use the Search button on the Functions palette to find the 
NI-RFSG palette. 
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7. Right-click the resource name input on the niRFSG Initialize VI, and select 
Create » Control to create a front panel control where you specify the 
NI RF signal generator device name. 
Figure 6. Resource Name Input on the niRFSG Initialize VI 

8. Right-click the frequency (Hz) input on the niRFSG Configure RF VI, and select 
Create » Control. 

9. Right-click the power level (dBm) input on the niRFSG Configure RF VI, and 
select Create » Control. 

10. Display the VI front panel by clicking it or by selecting Window » Show Front Panel. 
11. In the VI front panel power level (dBm) control, enter 0. In the frequency (Hz) 

control, enter 100M (100 MHz). 
12. In the VI front panel resource name control, enter the NI 5650/5651/5652 device 

name that you specified in MAX. 

Adding a While Loop 

Add a While Loop to continuously generate the signal and check the generation status 
until you click the Stop button. 

1. Display the VI block diagram, and select the While Loop on the Structures palette. 

2. Enclose the niRFSG Check Generation Status VI in the While Loop, as shown in the 
following figure. 
Figure 7. The niRFSG Check Generation Status VI Enclosed in the While Loop 

3. Right-click the While Loop tunnels, and select Replace with Shift Register. 

Tip You can use the Search button on the Functions palette to find the 
Structures palette. 
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4. Select the Or function on the Boolean palette. Place the function inside the While 
Loop. 

5. Wire the output of the Or function to the conditional terminal of the While Loop. 
6. Select the Unbundle by Name function on the Cluster, Class, & Variant palette. 

Place the function inside the While Loop. 
7. Wire the error out output of the niRFSG Check Generation Status VI to the 

Unbundle by Name function. 
8. Wire the output of the status element to an input of the Or function. 
9. Right-click the unused input of the Or function, and select Create » Control to 

create a Boolean control. 
10. In the VI front panel, right-click the Boolean control created in step 9, and select 

Replace » Modern » Boolean » Stop Button to create a Stop button. 
Figure 8. While Loop with Stop Button 

Adding an Error Indicator 

Add an error indicator to the VI front panel. 

1. Create an error indicator by right-clicking the error out output of the niRFSG 
Close VI and selecting Create » Indicator. 

2. Verify that the VI block diagram and VI front panel now look similar to the following 
figures. 
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Figure 9. Basic Sine Wave Generation VI Block Diagram 

Figure 10. Basic Sine Wave Generation VI Front Panel 

3. Open the VI front panel, and select the NI 5650/5651/5652 module name specified 
in MAX in the resource name control. 

4. Click the Run button on the toolbar to initiate sine wave generation. 
5. Click the VI front panel STOP button to stop sine wave generation. 

You have successfully generated a continuous sine wave signal using the NI-RFSG 
instrument driver and the NI 5650/5651/5652. 

Troubleshooting 

If an issue persists after you complete a troubleshooting procedure, search our 
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KnowledgeBase for additional information our technical support engineers create as 
they answer common user questions and resolve unexpected issues. 

Why Is the ACCESS LED Off When the Chassis Is On? 

The LEDs may not light until the device has been configured in MAX. Before 
proceeding, verify that the NI 5650/5651/5652 appears in MAX. 

If the ACCESS LED fails to light after you power on the chassis, a problem may exist 
with the chassis power rails, a hardware module, or the LED. 

1. Disconnect any signals from the module front panel. 
2. Power off the chassis. 
3. Remove the module from the chassis and inspect it for damage. Do not reinstall a 

damaged device. 
4. Reinstall the module in a different chassis slot. 
5. Power on the chassis. 
6. Verify that the device appears in MAX. 
7. Reset the device in MAX and perform a self-test. 

What Should I Do if the NI 5650/5651/5652 Does Not Appear in 
MAX? 

1. In the MAX configuration tree, expand Devices and Interfaces. 
2. Expand the Chassis tree to see the list of installed hardware, and press <F5> to 

refresh the list. 
3. If the module is still not listed, power off the system, ensure that all hardware is 

correctly installed, and restart the system. 
4. Navigate to the Device Manager by right-clicking the Start button, and selecting 

Device Manager. 
5. Verify the NI 5650/5651/5652 appears in the Device Manager. 

a. Under an NI entry, confirm that a NI 5650/5651/5652 entry appears. 

Notice Apply external signals only while the NI 5650/5651/5652 is powered 
on. Applying external signals while the device is powered off may cause 
damage. 
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b. If error conditions appear, reinstall NI-RFSG. 

What Should I Do if the NI 5650/5651/5652 Fails the Self-Test? 

1. Restart the system. 
2. Launch MAX. 

◦ Failed self-test—Perform self-calibration, then perform the self-test again. The 
NI 5650/5651/5652 must be calibrated to pass the self-test. 

◦ Failed self-calibration—Perform self-calibration again. 
3. Power off the chassis. 
4. Reinstall the failed module in a different slot. 
5. Power on the chassis 
6. Perform the self-test again. 

NI Services 

Visit ni.com/support to find support resources including documentation, downloads, 
and troubleshooting and application development self-help such as tutorials and 
examples. 

Visit ni.com/services to learn about NI service offerings such as calibration options, 
repair, and replacement. 

Visit ni.com/register to register your NI product. Product registration facilitates 
technical support and ensures that you receive important information updates from 
NI. 

NI corporate headquarters is located at 11500 N Mopac Expwy, Austin, TX, 78759-3504, 
USA. 

Note If you are using a PC with a device for PXI remote control 
system, under System Devices, also confirm that no error conditions 
appear for the PCI-to-PCI Bridge. 

© 2025 National Instruments Corporation. 
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